Customer Review

5 of 6 people found the following review helpful
5.0 out of 5 stars Excellent router (edited), 10 Jan 2013
Verified Purchase(What is this?)
This review is from: Asus RT-N66U - 900Mbps Dual Band Wireless N Router, Gigabit LAN/WAN, 2x USB, Print FTP UPnP VPN Server, IPv6, 8x SSID, Wireless 3D HD content streaming, 3 Year Warranty (Personal Computers)
Ok I tend not to give bad reviews unless really needed and I wouldn't say I dislike this router because I don't but I have had problems.

At first everything was working fine , fiddled about to get the feel of how it works.

Wireless is fantastic on this puppy and has a decent range !!! and it even works real good on those cheap android tablets that have poor wireless pickup !!!

Gui was simple and quite easy to navigate and its web access quite easy to use from anywere in the world too!!!

Now for the reason I give this 3 stars !!!! At first everything worked well Usenet downloaded max speed and internet loaded ultra fast !!! but after one day my usenet speed dropped and wouldn't go above 600KBs which is pretty poor compared to I was getting 6MBs !!! I though hey it may have been a setting I hit or changed upon setup and so I tried tweaking about !!! switched QoS on and forwarded the correct port but no go I turned it off but no go still 600Kbs. I thought hey my isp might be having issues and so I plugged my computer direct to modem and low and behold I was getting max speeds 6MBS.

I plugged router back in and reset modem and router so the isp could register the new mac and retried to download but again no go !!! so now I reset the router back to factory default to see if that solved the issue but again only 600KB and so again I fiddled about with every combination of things to do from QoS to disabling plugandplay etc ...

So I thought hey I updated the firmware as a new version was detected at start up , I then decided to flash the modem back to its original factory sent firmware and again no go still only 600KBs , I even loaded a merlin custom firmware too see if that helped but again no.

I tested http downloads and those worked fine , I tested the inbuilt nzb usenet app and that had the same problem.

Anyway I decided enough is enough !!! this is supposed to be an easy fast setup as the box says and so I had to return the router.

It is such ashame because it was an excellent router :( I would have ordered a direct replacement but I am cautious now and tend to not request a direct replacement of the same product , just in case the same happens !! :(

If anyone knows what the problem is or was I would appreciate a reply to my review .

edit

Well after getting a replacement everything works fine :) the problem was hardware error , I thought maybe it was a port error , although yes one port didn't work very well the others did :) but for some reason the failed router was not allowing any ports to pass though.

Now the router works 100% and must say im glad :)
Help other customers find the most helpful reviews 
Was this review helpful to you? Yes No

[Add comment]
Post a comment
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Amazon will display this name with all your submissions, including reviews and discussion posts. (Learn more)
Name:
Badge:
This badge will be assigned to you and will appear along with your name.
There was an error. Please try again.
Please see the full guidelines ">here.

Official Comment

As a representative of this product you can post one Official Comment on this review. It will appear immediately below the review wherever it is displayed.   Learn more
The following name and badge will be shown with this comment:
 (edit name)
After clicking on the Post button you will be asked to create your public name, which will be shown with all your contributions.

Is this your product?

If you are the author, artist, manufacturer or an official representative of this product, you can post an Official Comment on this review. It will appear immediately below the review wherever it is displayed.  Learn more
Otherwise, you can still post a regular comment on this review.

Is this your product?

If you are the author, artist, manufacturer or an official representative of this product, you can post an Official Comment on this review. It will appear immediately below the review wherever it is displayed.   Learn more
 
System timed out

We were unable to verify whether you represent the product. Please try again later, or retry now. Otherwise you can post a regular comment.

Since you previously posted an Official Comment, this comment will appear in the comment section below. You also have the option to edit your Official Comment.   Learn more
The maximum number of Official Comments have been posted. This comment will appear in the comment section below.   Learn more
Prompts for sign-in
 

Comments


Sort: Oldest first | Newest first
Showing 1-2 of 2 posts in this discussion
Initial post: 20 Jan 2013 21:40:36 GMT
M. Thompson says:
Virgin Media customer by any chance?

In reply to an earlier post on 20 Jan 2013 21:58:09 GMT
Davey says:
yes virgin media,

strange thing is the port works fine on my old router but on the new router it didn't , but I think the port im using is being throttled on the new router as a different port works fine.
‹ Previous 1 Next ›