Customer Discussions > kindle discussion forum

Can't connect to wi fi

Sort: Oldest first | Newest first
Showing 151-165 of 165 posts in this discussion
In reply to an earlier post on 18 Jan 2013 11:49:29 GMT
Last edited by the author on 18 Jan 2013 11:58:24 GMT
Jaydax says:
That's a nice theory but there are no other wi-fi routers anywhere near my house out in the country and I still had the dropped connection problem. I cured my woes by linking in a second wireless router to my network. I still get dropped connections but switching to the other router quickly puts me back online. That tends to make me think the problem is with the Kindle expecting a particular ip address and the router re-issuing a different one. Changing to a static ip address on a BT Home Hub 3 just doesn't seem to help though.

Here's what was involved in extending the network

In reply to an earlier post on 18 Jan 2013 13:41:31 GMT
K. A. Newton says:
I worked nights for 30 years so I have times when I am awake all day and all night but I can cat nap now I am retired.

I gave up trying and watched "Life on Earth" David Attenborough that I bought for my grandson instead with the computer switched off. The next morning "Manage my Kindle" page was all back to normal.

Posted on 28 Oct 2013 17:09:24 GMT
irene says:
why cant i connect to wifi on my brand new KINDLE DX...I have another kindle and have no problem.All the difference is the new one does NOT show connections PLEASE how do I connect

Posted on 3 Jan 2014 14:48:15 GMT
mo says:
Brand new Kindle won't connect to secured wifi, everything else does; PC, laptop, phone. The only way I can get my new kindle online is to unsecure my router, this is not really acceptable. Any ideas???

In reply to an earlier post on 3 Jan 2014 15:05:51 GMT
Damaskcat says:
Is your router set to use B G and N when it communicates with devices? Kindles can't use N.

Is your router using a channel higher than 11? Kindles will only use channels lower than that

Does your router have a WPS button? Have you tried using that button rather than typing in the password?

Are you typing the password incorrectly?

In reply to an earlier post on 3 Jan 2014 21:54:24 GMT
mo says:
Thanks for your help. Channel is < 11, password is correct. I'm afraid I don't know about B G and N nor WPS :(
My Kindle 3 works fine with the router.

Posted on 3 Jan 2014 22:20:45 GMT
Jaydax says:
How many devices are connected to your router? There seems to be a limit with some. When I reached it, I connected a second old wireless router with DHCP disabled - problem solved. Details of the process at

In reply to an earlier post on 4 Jan 2014 12:03:59 GMT
mo says:
It's usually just my laptop that's accessing the router

In reply to an earlier post on 4 Jan 2014 18:53:23 GMT
Jaydax says:
Don't forget mobile phones and other kindles will connect to your router too. If there are no other devices then try switching off your laptop and then connecting the Kindle. If it won't connect you have something set wrong. If it will connect then switch on the laptop and connect to Internet on that. If the laptop won't connect then the laptop and Kindle are both trying to use the same ip address. That would cause your problem.
Try this and if you run into the same problem get back to us with the exact model of the Kindle and your router so we can tell you how to fix it.

Posted on 4 Jan 2014 19:15:02 GMT
Manc girl says:
I had this problem and CS told me that Amazon and BT were a problem together and just wouldnt connect - I tried everything that CS asked me to do. I have given up and now connect via my iphone wifi no problem!!

In reply to an earlier post on 4 Jan 2014 19:44:48 GMT
Jaydax says:
I had this problem. I use BT. I extended my wireless network using an old router (non-BT). Problem fixed. Without the extra router switched on I get random disconnects.

In reply to an earlier post on 4 Jan 2014 23:30:31 GMT
mo says:
Have tried switching off all other devices with no success. However I finally resorted to switching off the security on my router and it all works fine. I think the problem is with my WPA-PSK security. I shall have to resort to switching it off whenever I want wifi on my kindle. It's a pain to have to do this but seems to be the only solution.

In reply to an earlier post on 5 Jan 2014 01:55:39 GMT
Jaydax says:
Switching off the router security isn't something I would want to do. If you really must do it then turn off the router's SSID so that it's name is not displayed. That's not as secure as having a password but it will help. You can still connect because your Kindles and laptop will already know the SSID

In reply to an earlier post on 5 Jan 2014 16:12:28 GMT
mo says:
Thanks Jaydax. Good idea

In reply to an earlier post on 21 Aug 2014 14:30:02 BDT
mo says:
New router solved problem
‹ Previous 1 2 3 4 5 6 7 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in

Recent discussions in the kindle discussion forum

Discussion Replies Latest Post
NEWS: Kindle Paperwhite Software Update 5.4.5
82 1 day ago
NEWS: Kindle Paperwhite Previous Generation Software Update Version 5.4.4
269 11 days ago
NEWS: Kindle Paperwhite Software Update Version 5.4.3
188 27 days ago
Kindle Paperwhite Software Update Version 5.4.2
359 13 Jun 2014
Kindle Paperwhite (Previous Generation) Software Update Version 5.3.9
58 6 Jul 2014
Introducing the all-new Kindle Fire HDX Tablets
551 12 hours ago
The all-new Kindle Paperwhite - the ultimate device for reading!
1018 17 Jul 2014
NEWS: Kindle Touch Software Update Version 5.3.7
87 29 Jun 2014
NEWS: Kindle Paperwhite Update Version 5.3.6
101 25 Apr 2014
New Kindle Help Forum Now Available
0 5 Jun 2013
NEWS: Kindle Paperwhite Update version 5.3.5
62 6 Aug 2013
Important Announcement from Amazon
697 4 days ago

More Customer Discussions

Most active community forums
Most active product forums

Amazon forums

This discussion

Discussion in:  kindle discussion forum
Participants:  93
Total posts:  165
Initial post:  7 Oct 2010
Latest post:  1 day ago

New! Receive e-mail when new posts are made.
Tracked by 14 customers

Search Customer Discussions