Customer Discussions > headphones discussion forum

Sennheisers - strange phenomenon!


Sort: Oldest first | Newest first
Showing 1-6 of 6 posts in this discussion
Initial post: 10 Sep 2010 21:31:23 BDT
Skylark says:
I bought a set of Sennheiser CX500 white earphones two years ago from Amazon: they were quite expensive, but the sound quality was excellent. I haven't used them over-much, but for some bizarre reason they've suddenly started malfunctioning.
Even turned up on full volume, the sound is muffled and low. On songs, the voice sounds far away, as though it's coming from the bottom of a coal mine! I can hardly hear the artist. The instruments are relatively a lot louder, but still not loud.
When I plug in a second pair of (cheaper)Sennheisers, the sound is perfect again. Can anyone explain why the sudden problem? I haven't changed earbuds or anything like that.
Many thanks.
Your reply to Skylark's post:
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
 

In reply to an earlier post on 11 Sep 2010 17:32:37 BDT
MC Zaptone says:
Gabrielle, two common problems for earphones:
1) The connection between the connection jack and the cable has become loose. This can happen without realising, usually by the earphones being pulled out of the Mp3 player by the cable rather than the connector jack or catching on something.
2) The buds have become gummed up by loose earwax and sweat, sounds nasty but happens all the time, specially by gym bunnies.

Unfortunately they may cost more to fix than replace. E-mail Sennheiser and ask there advice. They are a good company.

MC

In reply to an earlier post on 11 Sep 2010 21:54:38 BDT
Skylark says:
Thanks for your advice, MC - much appreciated.

Posted on 6 Oct 2010 12:48:58 BDT
J. Harris says:
As much as I love Sennheiser earphones, they always go wrong on me. I've probably got through about 5 pairs in just under 3 years. Thankfully, they have a 2 yr guarantee, but that's still really bad.

Posted on 10 Feb 2011 23:56:14 GMT
Last edited by the author on 10 Feb 2011 23:56:52 GMT
M Lynch says:
I too have a problem with Sennheiser, with the connection between the connection jack and the cable getting loose on more than 2 sets. They might be a good company, do make good headphones, but who needs the hassle? I avoid them now.

In reply to an earlier post on 15 Jul 2011 21:49:28 BDT
I agree but its also happened for me with koss, shure, igrado. One lesson keep yr receipt! My local HMV has kept me in headphones for years.
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the headphones discussion forum (30 discussions)

More Customer Discussions

Most active community forums
Most active product forums

Amazon forums
ARRAY(0x9cd81eac)
 

This discussion

Participants:  5
Total posts:  6
Initial post:  10 Sep 2010
Latest post:  15 Jul 2011

New! Receive e-mail when new posts are made.

Search Customer Discussions