Customer Discussions > The Wolverine [Blu-ray] forum

Does not play on Samsung BD-D5500


Sort: Oldest first | Newest first
Showing 1-3 of 3 posts in this discussion
Initial post: 19 Nov 2013 16:19:43 GMT
I received the Blu-ray of The Wolverine today and upon inserting the disc I saw a short "20th Century Fox" logo, followed by a red screen saying

"WARNING Your Blu-ray player requires an update in order to play this disc."

Naturally, there is no recent firmware update available for the Samsung BD-D5500 that would allow me to play this disc. Now I'm stuck with a nice £15 wolverine-themed coaster until an update enables my player to actually play it, which can take weeks, months or may not even happen at all, because my player is about two years old and more recent products (read: those that are still being sold and make the company money) are being favored when it comes to firmware updates.

Why is it so hard to roll out firmware updates among all major manufacturers first (Samsung is co-founder of the whole friggin' Blu-ray standard!) before releasing Blu-ray discs that actually require the respective updates? Why do studios leave paying customers hanging with an unusable product, while other people can enjoy their illegal copies without any such problems?

Here is another theory: do studios make the whole Blu-ray standard more inconvenient than necessary on purpose in order to promote their HD streaming services that would give them maximum control over their content? After all, there is a code for a Digital HD download in the Blu-ray box that would allow me to watch the movie even though the disc doesn't work. Of course I will not be tempted by that offer. I paid for a physical medium and I damn well want to use it. This is making me furious.

Posted on 25 Nov 2013 13:00:09 GMT
I found a solution to the problem. Yesterday I tried watching another movie that is being distributed by Fox Home Entertainment. Never Let Me Go. It greeted me with the same warning to update my player that greeted me when I tried playing the Wolverine Blu-ray. Since Never Let Me Go is from 2010 I suspected that a firmware update might have broken the compatibility with other older Fox titles as well, so I tested Aliens and A Good Day to Die Hard, both of which worked perfectly fine. Being at a loss I tested a pretty outrageous theory that I never would have thought off had'nt an old title like Never Let Me Go given me trouble. I removed my flash drive from the Samsung player and tried again. Suddenly Never Let Me Go worked. Then I tested The Wolverine and to my bafflement it worked as well! So clearly there is some kind of authoring problem going on with certain titles from Fox Home Entertainment that prevents them from working properly as long as a flash drive is attached to the (Samsung) player. How can something like that happen?

Posted on 22 Jan 2014 19:14:26 GMT
D. Fagan says:
Same thing happened to me today,I had to update my "old" player then the disc still wouldn't play for me.Luckily I gave one more try and turned my player off and on again then it worked somehow.I don't like all this update B.S..
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


 

This discussion

Participants:  2
Total posts:  3
Initial post:  19 Nov 2013
Latest post:  22 Jan 2014

New! Receive e-mail when new posts are made.
Tracked by 3 customers

Search Customer Discussions
This discussion is about
The Wolverine [Blu-ray]
The Wolverine [Blu-ray] by Hugh Jackman (Blu-ray - 2013)
4.2 out of 5 stars   (473)